\ More About Spreadsheet

In this chapter, you will learn about :
® Making custom lists with AutoFill
® Using the AutoFormat feature to apply pre-defined formats to worksheets
® formatting numbers and dates/times in various formats

® Applying alignment format features like merge cells, wrap text, horizontal
and vertical alignment, orientation, etc., to the selected cell or range of cells

® Printing a worksheet

You are already familiar with the basic feature of MS Excel 2010. In this chapter, you will learn
about the advanced features of this software.

As you have learned, AutoFill is a very powerful feature of Excel. It lets you fill the data in
series in adjacent cells. Here's a small exercise to see how much you remember about using
AutoFill.

MAKING CUSTOM LISTS WITH AUTOFILL

You know that in Excel you can get a ready-to-use list of months and week days using the
AutoFill feature. Similarly, you can also use this feature to create your own list-a list that you
use frequently. For example, suppose you are the president of the Cricket Club of your colony.
You want to maintain the records of the members of the club and hence, require the list of
their names several times. Instead of typing the names repeatedly, you can create a Custom
List in Excel.

To create a Custom List in Excel, follow | e oo B z ;
these steps: , -
Step 1 : Click on the File tab and then | ..~

click on Options. The Excel | - Ganer

Options dialog box appears on | -

t use Dynamic Data Exchange (DDE)

the screen.

it for A4 or 8.5 x 117 paper sizes

Step 2 : Click on the Advanced options
scroll down to the General
section and click the Edit W Opios
Custom Lists... button. :

Show custon abmitted Office com content

Step 3 : In the Custom Lists dialog box I
that appears, click the NEW LIST Co] o
option.

The Excel Options dialog box
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Step 4 : On the right-side pane under List entries,
type the list of names. Press the Enter key
after typing every name.

Step 5 : Click on the Add button.
Step 6 : Click on OK.
Step 7 : Close the Excel Options dialog box.

@

Step 8 : To use this list anywhere in your worksheet,
type any one name from the list.

Then use the AutoFill handle to drag down and
complete the list.

1 Member's Names
2 Nitu Verma

3 Arvind Verma

4 Aanand Thakur

5 Karan Sharma

6 Piyush Rastogi

7

8

Jai Aggarwal
Ashok Arora

| 9 Raman Singh
10 Vidhan Raghav
11 Dev Bhatiya
12 Kuldeep Sharma
13
A
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Custom Lists - 5 5
| Custom Lists
| Custom lists: List entries:
NEW LIST ~ | |Nitu Verma -
Sun, Mon, Tue, Wed, Thu, Fri, 5 Arvind Verma LAl
| Sunday, Mcndav, Tuesday, Wed) Aanand Thakur Delete
Jan, Feb, Mar, Apr, May, Jun, Ju Karan Sharma E. st
| Januarv Fehnmr\j.I March, April, Piyush Rastogi
Hitu Verma, Arvind Verma, Aane Jai Aggarwal
Ashok Arora
Raman Singh
Vidhan Raghav
Dev Bhatlya
" Kuldeep Sharma
Import list from cells: @ G Import
1
[ o | Cancel

Creating a new custom list

i

rs
Member's Names [
Askhok Arora
Karan Sharma
Piyush Rastogi
Nitu Verma
Jai Aggarwal
Arvind Verma
Raman Singh
Dev Bhatiya
Aanand Thakur
Kuldeep Sharma
Vidhan Raghav

| 100% (-)

Adding a custom list to the Excel worksheet
Your parents can use the Custom Lists feature to create a list of grocery items that they regularly

buy.

Km)@) You can delete a Custom List easily by selecting the list and clicking the Delete button from

he Custom Lists dialog box.
More) g
MJ

MORE ABOUT FORMATTING

Formatting allows you to define the structure and layout of a worksheet to make it presentable.
Formatting a worksheet not only makes it look good but also increases the readability of data.
This section tells you about some advanced formatting tools of Excel 2010.
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Adding AutoFormat Button on the Quick Access Toolbar

=l B

Excel offers some perdefined styles to format a worksheet. To use this feature, add the AutoFormat
button on the Quick Access Toolbar of the Excel window. To do this, the steps are as follows:

Step 1:

Step 2 :

Step 3 :

Step 4 :
Step 5 :
Step 6 :

Click on the File tab and then
click on Options. The Excel
options dialog box appears on
the screen.

Click on the Quick Access
Toolbar option. The Customize
the Quick Access Toolbar dialog
box appears on the screen.

From the Choose commands from
list, select Commands Not in the
Ribbon.

tomezations: | Reset=

Show Quick Access Tookar below the Ribben

ImgonyEsport =

[+ 4 Canced

Adding the AutoFormat button on the Quick Access

Click on the AutoFormat... option. Toolbar
Click on the Add button.
Click on Ok.

The Quick Access Toolbar will now show the AutoFormat button -] on it.

Formatting Numbers

You can format cells containing numbers in a desired format from the various options available

in Excel.

To format numbers, follow these steps:

Step 1 : Select the cells you want to format.

Step 2 : Right-click and select the Format Cells...
options from the drop down menu.

In the Format Cells dialog box that
appears, click on the Number tab and
select the desired format (for example,

Step 3 :

Before Formatting

Currency) under Category list.

After Formatying

G G
Sales Sales
3550 $3,550.00
5000 $5,000.00
4000 $4,000.00
2500 $2,500.00

Format Cells

|t

5 I'g";h_

Number Border | Fill [ Protection |
Cakegory:
General
Number
Currency

.| Sample

G Y
Accounting
Date

Time
Percentage
Fraction
Sdentific
Text
Special
Custom

Decimal places: 2

Symbol: % L'
Negative numbers:

-
$1,234.10

(£1,234.10)

($1,234.10)

Currency formats are used for general monetary values. Use Accounting formats to align decimal
points in a column.

(a) The Format Cells dialog box

Step 4 : You can now choose the number of decimal

places, symbol, etc. You will see an instant
preview in the Sample box. Click on Ok.

(b) Numbers before and after formatting
(omputer-b




Currency =

Percent format

| $ % o

Number

0
.00 .00

Number formatting tools

Currency format from
the drop Down List

the
launcher of the Number group of

You can also click on

the Home tab to open the Format

Increase/decrease )
( Cells dialog box.
decimal
Currency
$-% 2| %8%3
Number O

Shows a few other number formatting tools.

Formatting Date/Time

To format date/time in a worksheet, follow

these steps :

Step 1 : Select the cells containing a valid
date/time (in mm/dd/yyyy format).

Step 2 : Click on the Number tab in the
Format Cells dialog box. The steps
dialog box

to open Format Cells...

Format Cells

—

Number | Alignment | Font | Border | Fil | Protection
Category:

General Sample

Number .

Currency Sl

Aomunlini Type:

I +3/14/2001 - "
| ;m‘:mge *Wednesday, March 14, 2001 ="
Fraction 3/14 =

!l | | scientific 3/14/01
03/14/01
e 14-Mar
Special i ||l
Custom 14-Mar-01 ol
Locale (location):
English (U.S.) ]

Step 3 : Select the Date option from the

have been discussed earlier in the
chapter. '

Category list and choose the desired

Date formats display date and time serial numbers as date values. Date formats that begin with an
asterisk (*) respond to changes in regional date and time settings that are specified for the operating
system. Formats without an asterisk are not affected by operating system settings.

format.
Step 4 : Click on OK.

Formatting Text

[ o

] |

Cancel

—

—

The dialog box to format date

Formatting text may involve changing the alignment of text, font style, font size, orientation
of text, etc. You must already be familiar with some of the alignment tools available in the

Alignment group of the Home tab.

Before Formatting

Symbian Cricket Club

Member's Names  Date of Joining

Nitu Verma 1/1/2010|
Arvind Verma 10/1/2010|
Aanand Thakur 5/1/2010|
Karan Sharma 10/3/2010
Piyush Rastogi 3/15/2010|
Jai Aggarwal 6/6/2010|
Ashok Arora 7/6/2010|
Raman Singh 7/6/2010|
Vidhan Raghav 8/6/2010|
Dev Bhatiya 8/6/2010|
Kuldeep Sharma 6/20/2010|

Dates before and

After Formatting

Symbian Cricket Club
|Date of Joining

Member's Names

Nitu Verma Friday, January 01, 2010
Arvind Verma Friday, October 01, 2010
Aanand Thakur Saturday, May 01, 2010

Karan Sharma
Piyush Rastogi
Jai Aggarwal
Ashok Arora
Raman Singh
Vidhan Raghav
Dev Bhatiya
Kuldeep Sharma

Sunday, October 03, 2010
Monday, March 15, 2010
6/62010

Tuesday, July 06, 2010
Tuesday, July 06, 2010
|Friday, August 06, 2010
Monday, September 06, 2010
Sunday, June 20, 2010

ifter formatting



the Format Cells dialog box.

Do not forget to select the cell or range of cell to
which you want to apply formatting.

To open the Alignment tab, follow these steps :
Tools available in the Alignment group

| Number |[Alignment || Font | Border | Fil | Protection |
Text alignment Orientation
Horizontal: T
G ] ot ’ Step 1 : Select the «cells to be
'Bottom =] ¢ [ ree— formatted/aligned.
U t .|| Step 2 : Right-click and select the
7] Wrap text o = peaees | Format Cells option from the
!z‘:;:z:"zt - menu. The Format Cells dialog
A " box appears on the screen.
e Tl Step 3 : Click on the Alignment tab.
. You can see a variety of
' options.
| oK | Cancel .

The Alignment tab of the Format Cells dialog box

Table explains some of the commonly used alignment tools of this dialog box.
TABLE: Commonly used alignment tools in Excel

Feature Group Purpose EXAMPLE
Hori . . .
orizontal |Text alignment Aligns text horizontally across EYAMPLE
the cell.
Vertical Text alignment Aligns text vertically across
the cell. EXAMPLE
Wrap text |Text control (you can also|Folds the text in multiple || THIS TEXT
use the button “fwwprex |lines without increasing the|| IS WRAPPED
available in the Alignment | column width. WITEIérLTHE
group of the Home tab)
Shrink  to | Text control Reduces the font size to fit|[SHRINK TO FIT |
fit contents within the cell.

4 |
(omputer-b



Merge cells

Text control (you can
also use the =swewes coner-
button available in the
Alignment group of the

Merges multiple cell to make
a single cell.

MERGED CELLS

Home tab)
Orientation |Orientation Display the content of the N
cell at the desired angle. é\’g
&
&
PRINTING A WORKSHEET

You can take out a hard copy of your worksheet by printing it. Excel provides two options for
printing.
Quick Printing Option

To add the Quick Print options on the Quick Access Toolbar, follow EH E Py . (!
these steps: '

The Customize Quick
Access Toolbar button

Step 1 : Click on the Customize Quick Access Toolbar button to get
a drop down menu.

Step 2 : Select the option Quick Print from the list. The Quick Print button E will be made
available on the Quick Access Toolbar.

kel Save Print
7 Save As =
The Quick Print button on the Quick Access Toolbar WO S Copies: 1
Step 3 : Click this tool once to take a printout. If o
the printer is attached properly to your ™ Printer =
computer and is switched on, printing will Recent ,-;r;t::euet 1018 i
start automatically. Mo =
Settings

Save & Send

Printing from the Print Panel

Print Active Sheets

Only print the active sheets

You can open the Print Panel in Excel by following any

of the steps given below: Help sy 2L
1=| Print One Sided
Press Ctrl + P from the keyboard. =} Optione Only print on one side of the p..
kd Bt = = Collated o
OR =123 123 123
Click on the File tab and select the Print option. | =] PortitOrentation
| Letter

O R Bl w11 g

Press Alt + F + P from the keyboard.

The Print Panel

4 )
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After opening the Print Panel, change any of the settings as required, and click the Print button
on the print panel to begin printing.

Points to Remember

* You can create your own Custom List by using the AutoFill feature.
® The AutoFormat tool of Excel provides ready-to-use designs for formatting worksheets.

® The Format Cells dialog box provides options to format numbers, date/time, text etc. in desired
formats.

® The Alignment tab of Format Cells dialog box provides options to wrap text, merge multiple
cells, change the direction of the cell contents, and align cell contents horizontally or
vertically.

* You can take a printout of the worksheet either by using the Quick Print button or with the
help of the Print Panel under the File tab.

A. Tick (V) the correct option :

1. You can create of your own by using the Autofill feature.
(a) Readymade List () (b) Custom List () (c) Auto List ()
2. allows you to make your worksheet more presentable by defining its structure
and layout.
(a) Formatting () (b) Editing () (c) Printing ()
3. The formatting tool helps to fold the text in multiple lines within the cell.
(a) Merge Cell D (b) Wrap text D (c) Shrink to fit D
4. Tt reduces the font size to fit the contents within the cell.
(a) Orientation D (b) Merge cells D (c) Shrink to fit D
5. For formatting number and dates, you click on the tab of the Format Cells
dialog box:
(a) Border () (b) Font () (c) Number ()
B. Fill in the blanks :
1. Excel can automatically format a worksheet with the help of tool.
2. You can get a ready-to-use list of months and week days using the feature.
3. The keyboard shortcut for printing a worksheet is
4. Alignment group is present in tab.
5. option of the Alignment tab of Format cells dialog box reduces the font size

to fit the contents within the cell.

(omputer-b
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C. Match the columns given below :
1. Wrap text (a) Merge multiple cells to make a single cell
2. Orientation (b) Reduces the font size to fit the contents within the
cell.
3. Shrink to fit (c) Folds the text in multiple lines without

increasing the column width.

4. Merge to fit (d) Displays the content of the cell at the desired angle.

D. Answer the following Questions :

What is the use of AutoFill feature in Excel?

How do you format numbers in Excel? Explain with the help of an example.

Write the steps to add the AutoFormat button on the Quick Access Toolbar in Excel.
Write three different methods for taking a printout of your worksheet in Excel.
What is the purpose of formatting a worksheet in Excel?

Differentiate between vertical and horizontal cell alignment.

Write a short note on AutoFormat feature of Excel.

Write steps to quickly print a worksheet.

1.
2.
3.
4.
5.
6.
7.
8.
9.

Name the tools to do each of the following in Excel-
(a) Fold the text in multiple lines without increasing the column width
(b) Reduce the font size to fit the contents within the cell

ACTIVITY

1. If you right-click on a cell which shows some content, you will see the options Cut,
Delete and also Clear Contents. Which option does what? Explore and find the answer.

2

2. Create a Custom List in Excel that contains names of all the students in your class. Open
a new workbook and in five different worksheets (namely- Eng, Maths, Sc, SSt, Hindi).
Enter all the names using the AutoFill feature. Now enter marks scored by each student
in the 1st term. Save the workbook as My Class Result. xlsx.
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